Tube Amp Forum: The Ultimate Tone
Distorting reverb tube - Printable Version

+- Tube Amp Forum: The Ultimate Tone (https://theultimatetone.com)
+-- Forum: Tube Amp Community (Hi-fi too!) (https://theultimatetone.com/Forum-Tube-Amp-Community-Hi-fi-too)
+--- Forum: Preamp Mods & Design (https://theultimatetone.com/Forum-Preamp-Mods-Design)
+--- Thread: Distorting reverb tube (/Thread-Distorting-reverb-tube)

Pages: 1 2


Distorting reverb tube - Tomislaw - 06-26-2020

Hello,

I'm having a bit of a problem troubleshooting a Fender type reverb - the 12AT7 driver tube output has a tendency to distort the signal. Originally with a bypassed 1K cathode resistor the tube was oscillating wildly. I increased the Rk value to 2,2K bypassed which stopped the oscillation but the top of the signal was still distorted. Removing the bypass cap obviously reduces the gain in the triode and I can make up for that by lowering the Rk value to 470R. At maximum V1 output volume I'm getting 154Vpp signal swing whereas with a bypassed 2,2K Rk it was around 195Vpp. At 154Vpp reverb sounds OK. Voltage drop at Rk is now 4,7V and plate voltage measured cathode to plate is 340V, so the plate dissipation is still within spec.
The signal at the grid is clean and undistorted. There's a 430K grid stopper and a 680K grid leak. Reverb transformer sees 360V.

Is there any other way of fixing the problem with the reverb driver?


Tomi


RE: Distorting reverb tube - Strelok - 07-08-2020

Hi Tomi!

You have a lot of answers for your own question, are these things you do not want to do?

It could be that some resistiors drifted off value, having a much lower resistance than the official value.

Maybe the tube is bad, but I think you tried that already.
Changing to a 12AY7 might help, or a 12AU7.

You could try changing RA.

Strelok


RE: Distorting reverb tube - Strelok - 07-08-2020

Wait!

A 12AT7 can handle more current than a 12AX7!
Twice as much actually.
I don't know about 12AY7 or 12AU7, don't try that without checking!

Strelok


RE: Distorting reverb tube - Tomislaw - 07-09-2020

Hi Strelok,

I was only curious if there was another workaround for this problem. As it turned out, the 470R cathode resistor eventually made the tube oscillate again, so I switched it back to the stock value of 1K without the bypass cap. There was still enough signal swing to make the reverb sound OK. I couldn't actually play with Ra as the tube drives a reverb transformer and both triodes are wired in parallel to allow more current through. The amp suffered from a number of other issues like random ground connections causing ground loops, and there was a really nasty one in the reverb circuit. It had a Vox AC30 4xEL84 power output section with one shared 56R Ck and 100R screen resistors. Each tube was dissipating ~15W of heat in this configuration.

Tomi


RE: Distorting reverb tube - K O'Connor - 07-09-2020

Hi Guys

The 470 Rk value for the reverb driver is actually okay, but the effect on the tube gain may be problematic for given layouts In an old Fender chassis I used for trying circuits out in, the stock R was 470 even though the schematic suggested a different value.

It is important in the SE circuit to have a high-value good-quality filter cap for the related supply node. Remember, PSRR is nonexistent in such a circuit, so the supply has to be quiet on its own otherwise you get IM products into the reverb tank. In the worst case that can sound as if the reverb is wildly distorted and in the best case simply that the reverb is muddy. Obviously, a bad filter cap can cause a lot of supply-modulated bad sound.

You can scope the drive into the OT using a 100x probe (if using a DSO). Visual distortion of a sine wave represents quite a high figure of THD, but it's what most people have to go by. You can also send a signal into the return path to make sure that section is clean unto itself.

EL-34s dissipating 15W is no problem; if you meant EL-84, then it is a problem and Rk needs to be split (ideally) and/or made higher in value. Those 100R screen-stops will cause the amp to eat tubes.

have fun


RE: Distorting reverb tube - Tomislaw - 07-09-2020

Yes, of course I meant EL84's, my mistake. I split Rk/Ck and adjusted the resistor values to cool down the tubes. 168R per side took the dissipation down below 12 watts. I increased screen resistors' values to 1K and I don't think that changed the sound much.

The amp was an interesting case and I have learnt quite a lot working on it. I was only to switch the PT wiring to 230V but I noticed the amp hums a bit too much so I had to investigate that. There were many random ground connections and I had to convert everything to galactic ground. I then experienced all sorts of unpredictable behaviour when the amp would stop humming and buzzing one day and start over again the next day. Turned out the reverb driver tube was oscillating and upsetting the V1, which was quite misleading at first. I fixed that by installing a bypassed 2K2 Rk usually found in typical Fender-style reverb circuits. The tube stopped oscillating right away but the sound coming out of the reverb was noticeably harsh. I scoped the tube to see what's going on and found the distorted output. I then only had to find the optimal Rk value so there was enough signal swing to drive the reverb without distortion and the tube was not oscillating. Typical values didn't work as expected and the circuit had to be carefully tweaked to get decent performance. Three other 12AT7's behaved exactly the same way in this position so the problem was not caused by a faulty tube.

The offending tube was on the screen supply which was well filtered, but didn't have an individual filter cap as such.


RE: Distorting reverb tube - K O'Connor - 07-09-2020

Hi Tomislaw

The reverb driver needs decoupling from the screen node, or from whatever node it is powered from in any build. The SE driver seems more problematic in this regard, being sensitive to layout and where its power comes from, where the push-pull driver does not have that issue.

Have fun


RE: Distorting reverb tube - Strelok - 07-13-2020

Oh yes, of course, the Tx is RA.

Thank you very much all, the info in this thread is a very handy reference.


RE: Distorting reverb tube - nauta - 07-13-2020

Hey Strelok

What does RA mean?


RE: Distorting reverb tube - Tomislaw - 07-16-2020

(07-09-2020, 11:17 PM)K O\Connor Wrote: The reverb driver needs decoupling from the screen node, or from whatever node it is powered from in any build. The SE driver seems more problematic in this regard, being sensitive to layout and where its power comes from, where the push-pull driver does not have that issue.

I provided additional caps, but in this particular case their presence didn't prevent the tube from distorting the signal. But that's not the end of the story as I've got more amps on my bench right now. A friend of mine is a fan of American boutique amps and he's got several dozens of them, they're mostly still wired for 120V and I've been going over them changing taps on PTs and checking their overall condition while I'm at it. The ones with reverb tanks seem to need more attention as the reverb circuit usually introduces a lot of noise into the signal. One example - another amp with a typical Fender style reverb would start humming/buzzing when the Reverb knob was turned up. First of all, the input grid on the reverb recovery tube was floating and would pick up all sorts of noise. I added a typical 220K grid leak and that already made a big difference, but there was still some buzz to get rid of. What was causing it was the return RCA jack grounded at the chassis even though it was directly wired to the PCB ground. Isolating the jack from the chassis fixed the problem completely. That was a quick win but at first the amp looked like a nightmare to troubleshoot - two sided PCB and carbon comp resistors in all signal paths. At least plate load ones were metal oxide.

There's next one from another builder that I'm working on right now and this one will keep me busy for some time. First of all its EL34's were idling at 60mA each and they must have been doing so for quite a long time as their bases already changed colour. Then after an hour of testing the 5AR4 rectifier gave up with a flash, I installed another one and I can sometimes see the arcing inside when the standby switch is being turned off. I guess it's time to add protecting diodes on the rectifier as the first filter cap is 20 or 40uF, no more. The amp even has a ground switch with a death cap even though there's a 3-prong cable installed. I snipped the orange drop cap off immediately, what's the point of putting it there? Pure nostalgia or vague noise suppression method maybe? Weird tube arrangement as well, probably messed up big time by the previous owner. 12AX7 as the reverb driver and ECC832 as a reverb recovery tube. I could see one the scope how the second V1 triode is going nuts when the volume knob is past 9. By the way, all potentiometers are wired CCW which is very annoying! ECC832 in V1 position works fine and that's how it was probably designed. Newer versions use 12AX7 there, but - of course - there's no tube chart in the amp. As usual - the 12AT7 is distorting at the plate and probably the Ck bypass cap will have to go again, like in the case I described above. But wait, there's more! Carbon comp screen resistors are so nice to see and they even used those on the entire B+ line. There are no grid stoppers, no voltage decoupling, but there's plenty of random chassis ground connections. There's not even a single shielded cable inside the chassis and there's only one fuse for an entire amp. Not bad for a pricey build which is nothing more than a Princeton Reverb clone with a TMB tonestack and EL34 power section. Anyway, I'm really looking forward to making it usable again - it's a good lesson in troubleshooting. 

Tomi


RE: Distorting reverb tube - nauta - 07-16-2020

Hey Tomi
That second amp sounds like you practically have to rebuild it Huh
That's a lot of work, man, glad I don't have to do it.

Good luck


RE: Distorting reverb tube - Tomislaw - 07-17-2020

Thanks, Nauta.

Some interesting observations: this build is very prone to severe oscillation problems. Preamp tubes are poorly decoupled: V1 (two stacked gain stages) and V3 (reverb recovery + gain stage) are on the same supply node. I don't have spare electrolytic caps at the moment but I did notice that probably the oscillation is directly caused by a nasty ground loop from both RCA reverb jacks grounded at the chassis. Isolating them keeps the tubes from oscillating and it's a quick fix for the problem, but the voltage supply line should still be upgraded.
One of the original EL34's that got battered so much made the carbon comp screen resistor start smoking yesterday. Glad I noticed that before it burst into flames.


RE: Distorting reverb tube - K O'Connor - 07-17-2020

Hi Tpmi

I was surprised that you were glad to see carbon screen resistors - unless you meant that sarcastically Smile

As always, screen resistors should always be replaced by flame-proof types and preferably the value increased to 1k to protect the tubes, as TUT pointed out decades ago. Most manufacturers have followed that advice since 1995. TUT specified using a 5W wire-wound to assure that the new Rs would be flame-proof. Small amps can use a 1-3W metal-oxide type provided it is flame-proof - not those red "flame resistant" Philips resistors, which will actually burn quite easily.

Have fun


RE: Distorting reverb tube - Strelok - 07-18-2020

(07-13-2020, 11:08 AM)nauta Wrote: Hey Strelok

What does RA mean?

Hoi Nauta!
I think it means the resistor tied to the anode/plate.
Like RK means the resistor tied to the kathode.

That is if I don't get it wrong Smile


Strelok


RE: Distorting reverb tube - Tomislaw - 07-23-2020

(07-17-2020, 10:40 AM)K O\Connor Wrote: I was surprised that you were glad to see carbon screen resistors - unless you meant that sarcastically Smile

Of course I'm being sarcastic. 

More fun with the amp I mentioned above - 12AT7 as a reverb driver (V2) upsets nearby V1 big time despite both tubes being individually decoupled and sitting on different supply nodes. Curiously enough - 12AX7 works perfectly fine there at any preamp output level. I got rid of all problems with hum/buzz, but I had to rebuild the whole thing.


RE: Distorting reverb tube - K O'Connor - 07-23-2020

Hi Tomislaw

Is this interaction between the reverb driver and the preamp tube before or after changing the grounding? Because the reverb driver is a small power amp unto itself, it is sometimes beneficial to place it out of sequence as far as the signal path goes, and/or to give it a huge filter cap of its own.


RE: Distorting reverb tube - Tomislaw - 07-23-2020

(07-23-2020, 01:19 PM)K O\Connor Wrote: Is this interaction between the reverb driver and the preamp tube before or after changing the grounding? Because the reverb driver is a small power amp unto itself, it is sometimes beneficial to place it out of sequence as far as the signal path goes, and/or to give it a huge filter cap of its own.

It was still happening after the reconstruction but only with the 12AT7 in place. The amp had a different tube there when I got it, but I assumed they had been changed and possibly mixed up at some point and since it's basically a slightly modified Princeton Reverb circuit, I thought the 12AT7 should be reinstated as in the original Fender amp. There were so many other potential causes of oscillation/intermodulation that I thought the problem was not actually caused by this particular type of tube. But I think I also tried the 12AX7 in V2 before the reconstruction and it was even worse. 

Reverb driver is on the screen node along with the first half of V4 which is the tremolo oscillator, but I added 8K2 and 12K resistors between them and installed two 22uF caps. V4B (concertina phase inverter) had its own stock filter cap. I also separated V1 and V3 with a 10K resistor as they were hanging off the same node, and added a 22uF decoupling cap for each tube. 

V1 was running smooth without V2 in the socket, regardless of the preamp output volume. Probably the 12AT7 should have been biased a bit cooler, but I left the stock Rk/Ck values when it turned out the 12AX7 does the job. I actually ended up putting the ECC832 from the original tube complement in there. But it was kind of surprising to see a lower mu tube cause some trouble, but it wasn't the case of a reverb driver actually clipping the plate signal.

Another lesson learned - don't waste your time trying to troubleshoot an amp with really bad grounding and shielding. I thought I'd be able to get away with just a few quick fixes, but not this time.


RE: Distorting reverb tube - Tomislaw - 09-03-2020

Even more fun with reverbs in Fender clones. I'm builing a second AA1164 Princeton Reverb now with some design modifications like additional decoupling, elevated heaters, proper ground wiring etc. The reverb driver tube is doing some weird things in both builds and I have no idea what to think about it. Reverb sounds OK, but scoping the V2 plate I see how it starts to distort and most likely oscillate when the preamp volume pot is turned up. Actually the voltage swing on the 12AT7 grid is quite high at the maximum preamp output, around 66V peak to peak. The signal is fed to the grid through a 500pF capacitor and there's a 1M grid leak and a 47K grid stopper (not included in the original schematic). As expected, increasing the grid stopper value does not prevent the oscillation and attenuating the signal at the V2 input makes the output too low to drive the reverb tank. No improvement with different Rk values either. Design mistake perhaps?

I'm going to examine the wiring again to make sure there's no ground loop or interference with the tremolo circuit which is on the same power node as the reverb driver, running from the Vs filter cap. I think I will temporarily disconnect the oscillator triode, leaving only the V2 which is already properly decoupled. The ground wiring follows the supply node arrangement, meeting the main ground bus at the Vs filter cap. It looks like this:

Galaxy 1:
Star 1 (preamp): input jacks, V1A and V1B cathode resistors, 6K8 eq resistor, Vol pot
Star 2 (reverb recovery): V3A grid leak, reverb off switch, V3A Rk, reverb pot
Star 3 (V3B gain stage): NFB tail resistor and speaker jack
Star 4 (phase inverter): 56K tail resistor
Star 5 (power amp): V5, V6 cathodes
Galaxy 2:
Star 1 (reverb driver): grid leak, Rk and reverb transformer secondary
Star 2 (tremolo): grid leak, V4A Rk, 22nF cap, 100K resistor and tremolo off switch


RE: Distorting reverb tube - K O'Connor - 09-03-2020

Hi Tomislaw

Keep in mind that in Fender's expected use of this amp there would NEVER be a 66V signal of any proportion at the input to the reverb driver.

The PA has a closed-loop gain of 55, so a 20V output at the speaker requires just 365mV at the PA input. This is where the 3M3||10pF meets the 470k grid-leak and the 470k from the reverb recovery stage. The attenuation through the dry path is about a factor of seven, so only 2v5 is needed from the preamp for the 20V at the speaker.

Is there a signal threshold where the reverb oscillation starts?

A later version of the Princeton (019320) has a 220k in series to the reverb driver and a 560pF from cathode to plate. They added a tube so the reverb and trem could match the concurrent models and most circuitry was standardised even though it meant the Princeton would be more expensive to build.

The ground groupings look questionable:

V1A,B are cascaded stages and even Fender did not tie their grounds together. They did however tie the reverb driver cathode to the V1B ground, which is not problematic for their intended use of the amp and "reasonable" signal levels.

V3A reverb recovery okay

V3B trem should ground to Vs cap along with bias since the amp uses bias-modulation.

V4 is the PA gain and concertina. NFB and reverb pot can be tied here. The concertina really should have its own filter since it provides a supply-referenced signal plus a ground-referenced one.

Have fun


RE: Distorting reverb tube - K O'Connor - 09-03-2020

Hi Tomislaw

One other thing: Since the closed-loop gain of the PA is so high, at least diagnostically it might be worth shorting out the 47R to see if stability returns? In any case, you can also hear how that sounds. bass might be a bit looser.

Have fun